aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/archcheck/Makefile
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-03-17 14:05:49 +0000
committerGitHub <noreply@github.com>2021-03-17 14:05:49 +0000
commit5feea4497f416eafdf54f34c2b9c67ddcef3f26f (patch)
treee92427a879159b38441e6b3fc4f0e45ebc75e579 /fpga_interchange/examples/archcheck/Makefile
parent701587241fb8d4b490c4998ab3f2590bc09d7f55 (diff)
parent01a95faf211d5947415ed6a9ea2b1fbedf1074cd (diff)
downloadnextpnr-5feea4497f416eafdf54f34c2b9c67ddcef3f26f.tar.gz
nextpnr-5feea4497f416eafdf54f34c2b9c67ddcef3f26f.tar.bz2
nextpnr-5feea4497f416eafdf54f34c2b9c67ddcef3f26f.zip
Merge pull request #619 from acomodi/add-cmake-infra-fpga-interchange
Add CMake infrastructure for fpga interchange
Diffstat (limited to 'fpga_interchange/examples/archcheck/Makefile')
-rw-r--r--fpga_interchange/examples/archcheck/Makefile23
1 files changed, 0 insertions, 23 deletions
diff --git a/fpga_interchange/examples/archcheck/Makefile b/fpga_interchange/examples/archcheck/Makefile
deleted file mode 100644
index 02e1c08e..00000000
--- a/fpga_interchange/examples/archcheck/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-include ../common.mk
-
-PACKAGE := csg324
-
-.PHONY: check check_test_data
-
-check: check_test_data
- $(NEXTPNR_BIN) \
- --chipdb $(BBA_PATH) \
- --package $(PACKAGE) \
- --test
-
-check_test_data:
- $(NEXTPNR_BIN) \
- --chipdb $(BBA_PATH) \
- --package $(PACKAGE) \
- --run $(NEXTPNR_PATH)/python/check_arch_api.py
-
-debug_check_test_data:
- gdb --args $(NEXTPNR_BIN) \
- --chipdb $(BBA_PATH) \
- --package $(PACKAGE) \
- --run $(NEXTPNR_PATH)/python/check_arch_api.py