aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/boards
diff options
context:
space:
mode:
authorAlessandro Comodi <acomodi@antmicro.com>2021-03-23 20:35:53 +0100
committerAlessandro Comodi <acomodi@antmicro.com>2021-03-23 21:05:58 +0100
commit15e945aa1c83d5408f93e6375b38ec81deb4f874 (patch)
treeb4d4801916cb71352284657c0183d3685c4bb7e2 /fpga_interchange/examples/boards
parent2956a0ca03d3e7e4573ed3f44de6fec23d33018e (diff)
downloadnextpnr-15e945aa1c83d5408f93e6375b38ec81deb4f874.tar.gz
nextpnr-15e945aa1c83d5408f93e6375b38ec81deb4f874.tar.bz2
nextpnr-15e945aa1c83d5408f93e6375b38ec81deb4f874.zip
interchange: added boards and group testing across multiple boards
Signed-off-by: Alessandro Comodi <acomodi@antmicro.com>
Diffstat (limited to 'fpga_interchange/examples/boards')
-rw-r--r--fpga_interchange/examples/boards/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/fpga_interchange/examples/boards/CMakeLists.txt b/fpga_interchange/examples/boards/CMakeLists.txt
new file mode 100644
index 00000000..18c8f96b
--- /dev/null
+++ b/fpga_interchange/examples/boards/CMakeLists.txt
@@ -0,0 +1,29 @@
+add_board(
+ name arty35t
+ device xc7a35t
+ package csg324
+)
+
+add_board(
+ name arty100t
+ device xc7a100t
+ package csg324
+)
+
+add_board(
+ name nexys_video
+ device xc7a200t
+ package sbg484
+)
+
+add_board(
+ name basys3
+ device xc7a35t
+ package cpg236
+)
+
+add_board(
+ name zybo
+ device xc7z010
+ package clg400
+)