aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/boards
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-03-25 16:03:22 +0000
committerGitHub <noreply@github.com>2021-03-25 16:03:22 +0000
commitf233bee9701ea191862d26616d68dab08ba7d2b0 (patch)
treea23f37b687bffa78976d39df4c212407e539732c /fpga_interchange/examples/boards
parent3cc50a5744beeae63ffb9ecd2064666e90d26be4 (diff)
parentc4cb86efe9dece4a837bdd490f5d7f78d2b4480f (diff)
downloadnextpnr-f233bee9701ea191862d26616d68dab08ba7d2b0.tar.gz
nextpnr-f233bee9701ea191862d26616d68dab08ba7d2b0.tar.bz2
nextpnr-f233bee9701ea191862d26616d68dab08ba7d2b0.zip
Merge pull request #628 from acomodi/add-interchange-devices
fpga_interchange: add more devices
Diffstat (limited to 'fpga_interchange/examples/boards')
-rw-r--r--fpga_interchange/examples/boards/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/fpga_interchange/examples/boards/CMakeLists.txt b/fpga_interchange/examples/boards/CMakeLists.txt
new file mode 100644
index 00000000..18c8f96b
--- /dev/null
+++ b/fpga_interchange/examples/boards/CMakeLists.txt
@@ -0,0 +1,29 @@
+add_board(
+ name arty35t
+ device xc7a35t
+ package csg324
+)
+
+add_board(
+ name arty100t
+ device xc7a100t
+ package csg324
+)
+
+add_board(
+ name nexys_video
+ device xc7a200t
+ package sbg484
+)
+
+add_board(
+ name basys3
+ device xc7a35t
+ package cpg236
+)
+
+add_board(
+ name zybo
+ device xc7z010
+ package clg400
+)