aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-03-17 14:05:49 +0000
committerGitHub <noreply@github.com>2021-03-17 14:05:49 +0000
commit5feea4497f416eafdf54f34c2b9c67ddcef3f26f (patch)
treee92427a879159b38441e6b3fc4f0e45ebc75e579 /fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt
parent701587241fb8d4b490c4998ab3f2590bc09d7f55 (diff)
parent01a95faf211d5947415ed6a9ea2b1fbedf1074cd (diff)
downloadnextpnr-5feea4497f416eafdf54f34c2b9c67ddcef3f26f.tar.gz
nextpnr-5feea4497f416eafdf54f34c2b9c67ddcef3f26f.tar.bz2
nextpnr-5feea4497f416eafdf54f34c2b9c67ddcef3f26f.zip
Merge pull request #619 from acomodi/add-cmake-infra-fpga-interchange
Add CMake infrastructure for fpga interchange
Diffstat (limited to 'fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt')
-rw-r--r--fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt b/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt
new file mode 100644
index 00000000..ce5d5d2d
--- /dev/null
+++ b/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt
@@ -0,0 +1,14 @@
+generate_xc7_device_db(
+ device xc7a35t
+ part xc7a35tcsg324-1
+ device_target xc7a35t_target
+)
+
+generate_chipdb(
+ family ${family}
+ device xc7a35t
+ part xc7a35tcsg324-1
+ device_target ${xc7a35t_target}
+ bel_bucket_seeds ${PYTHON_INTERCHANGE_PATH}/test_data/series7_bel_buckets.yaml
+ test_package csg324
+)