aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/devices/xc7z010/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Comodi <acomodi@antmicro.com>2021-03-17 18:43:29 +0100
committerAlessandro Comodi <acomodi@antmicro.com>2021-03-23 20:36:23 +0100
commit336d31cbcf592455abdbefc01ec5c6f87914b4f3 (patch)
tree339cbe71a677180a466fbab7a6718fd449d6f759 /fpga_interchange/examples/devices/xc7z010/CMakeLists.txt
parent3cc50a5744beeae63ffb9ecd2064666e90d26be4 (diff)
downloadnextpnr-336d31cbcf592455abdbefc01ec5c6f87914b4f3.tar.gz
nextpnr-336d31cbcf592455abdbefc01ec5c6f87914b4f3.tar.bz2
nextpnr-336d31cbcf592455abdbefc01ec5c6f87914b4f3.zip
fpga_interchange: add more devices
Signed-off-by: Alessandro Comodi <acomodi@antmicro.com>
Diffstat (limited to 'fpga_interchange/examples/devices/xc7z010/CMakeLists.txt')
-rw-r--r--fpga_interchange/examples/devices/xc7z010/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/fpga_interchange/examples/devices/xc7z010/CMakeLists.txt b/fpga_interchange/examples/devices/xc7z010/CMakeLists.txt
new file mode 100644
index 00000000..c0ee37df
--- /dev/null
+++ b/fpga_interchange/examples/devices/xc7z010/CMakeLists.txt
@@ -0,0 +1,14 @@
+generate_xc7_device_db(
+ device xc7z010
+ part xc7z010clg400-1
+ device_target xc7z010_target
+)
+
+generate_chipdb(
+ family ${family}
+ device xc7z010
+ part xc7z010clg400-1
+ device_target ${xc7z010_target}
+ bel_bucket_seeds ${PYTHON_INTERCHANGE_PATH}/test_data/series7_bel_buckets.yaml
+ test_package clg400
+)