aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/devices
diff options
context:
space:
mode:
authorAlessandro Comodi <acomodi@antmicro.com>2021-03-12 12:25:41 +0100
committerAlessandro Comodi <acomodi@antmicro.com>2021-03-16 15:39:01 +0100
commitd77d0ff34a3e183ad4f9f1d8af7eddad55e0929e (patch)
treec345b522c3a878a7132cbae2dce572045aa9d7f0 /fpga_interchange/examples/devices
parent701587241fb8d4b490c4998ab3f2590bc09d7f55 (diff)
downloadnextpnr-d77d0ff34a3e183ad4f9f1d8af7eddad55e0929e.tar.gz
nextpnr-d77d0ff34a3e183ad4f9f1d8af7eddad55e0929e.tar.bz2
nextpnr-d77d0ff34a3e183ad4f9f1d8af7eddad55e0929e.zip
fpga_intrchange: add cmake infrastructure to generate chipdbs
Signed-off-by: Alessandro Comodi <acomodi@antmicro.com>
Diffstat (limited to 'fpga_interchange/examples/devices')
-rw-r--r--fpga_interchange/examples/devices/CMakeLists.txt1
-rw-r--r--fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt2
2 files changed, 3 insertions, 0 deletions
diff --git a/fpga_interchange/examples/devices/CMakeLists.txt b/fpga_interchange/examples/devices/CMakeLists.txt
new file mode 100644
index 00000000..5b96ac80
--- /dev/null
+++ b/fpga_interchange/examples/devices/CMakeLists.txt
@@ -0,0 +1 @@
+add_subdirectory(xc7a35t)
diff --git a/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt b/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt
new file mode 100644
index 00000000..2b0dce53
--- /dev/null
+++ b/fpga_interchange/examples/devices/xc7a35t/CMakeLists.txt
@@ -0,0 +1,2 @@
+generate_chipdb(part xc7a35tcsg324-1)
+generate_chipdb(part xc7a35tcpg236-1)