aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/template.mk
diff options
context:
space:
mode:
authorKeith Rothman <537074+litghost@users.noreply.github.com>2021-02-19 17:28:25 -0800
committerKeith Rothman <537074+litghost@users.noreply.github.com>2021-02-23 14:09:28 -0800
commit5574455d2a20d3bb950e5dd907ef193d049a2a26 (patch)
tree575a82d63b89f61f0a6d96afd33f3bd804dcfad8 /fpga_interchange/examples/template.mk
parent2fc353d5592b0bf9ed8428545bbd6a64312cc16e (diff)
downloadnextpnr-5574455d2a20d3bb950e5dd907ef193d049a2a26.tar.gz
nextpnr-5574455d2a20d3bb950e5dd907ef193d049a2a26.tar.bz2
nextpnr-5574455d2a20d3bb950e5dd907ef193d049a2a26.zip
Working FF example now that constant merging is done.
Signed-off-by: Keith Rothman <537074+litghost@users.noreply.github.com>
Diffstat (limited to 'fpga_interchange/examples/template.mk')
-rw-r--r--fpga_interchange/examples/template.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/fpga_interchange/examples/template.mk b/fpga_interchange/examples/template.mk
index d12a4e11..c795544e 100644
--- a/fpga_interchange/examples/template.mk
+++ b/fpga_interchange/examples/template.mk
@@ -55,6 +55,15 @@ verbose: build/$(DESIGN).netlist
--package $(PACKAGE) \
--verbose
+verbose2: build/$(DESIGN).netlist
+ $(NEXTPNR_BIN) \
+ --chipdb $(BBA_PATH) \
+ --xdc $(DESIGN).xdc \
+ --netlist build/$(DESIGN).netlist \
+ --phys build/$(DESIGN).phys \
+ --package $(PACKAGE) \
+ --debug
+
debug: build/$(DESIGN).netlist
gdb --args $(NEXTPNR_BIN) \
--chipdb $(BBA_PATH) \
@@ -63,6 +72,15 @@ debug: build/$(DESIGN).netlist
--phys build/$(DESIGN).phys \
--package $(PACKAGE)
+debug_verbose: build/$(DESIGN).netlist
+ gdb --args $(NEXTPNR_BIN) \
+ --chipdb $(BBA_PATH) \
+ --xdc $(DESIGN).xdc \
+ --netlist build/$(DESIGN).netlist \
+ --phys build/$(DESIGN).phys \
+ --package $(PACKAGE) \
+ --verbose
+
build/$(DESIGN).dcp: build/$(DESIGN).netlist build/$(DESIGN).phys $(DESIGN).xdc
RAPIDWRIGHT_PATH=$(RAPIDWRIGHT_PATH) \
$(RAPIDWRIGHT_PATH)/scripts/invoke_rapidwright.sh \