aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/tests/ram
diff options
context:
space:
mode:
authorAlessandro Comodi <acomodi@antmicro.com>2021-04-07 12:07:10 +0200
committerAlessandro Comodi <acomodi@antmicro.com>2021-04-14 14:36:07 +0200
commitdfc9c3df8c016c26d8abe985d313b1bf81b4cc82 (patch)
tree9980d457fe97f3db67ba8dc16287bf9c607b0eb8 /fpga_interchange/examples/tests/ram
parent2912860c9788033a7501726e77bb4962b394280d (diff)
downloadnextpnr-dfc9c3df8c016c26d8abe985d313b1bf81b4cc82.tar.gz
nextpnr-dfc9c3df8c016c26d8abe985d313b1bf81b4cc82.tar.bz2
nextpnr-dfc9c3df8c016c26d8abe985d313b1bf81b4cc82.zip
interchange: add FASM generation target and clean-up tests
Signed-off-by: Alessandro Comodi <acomodi@antmicro.com>
Diffstat (limited to 'fpga_interchange/examples/tests/ram')
-rw-r--r--fpga_interchange/examples/tests/ram/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/fpga_interchange/examples/tests/ram/CMakeLists.txt b/fpga_interchange/examples/tests/ram/CMakeLists.txt
index 4625edb3..56db4870 100644
--- a/fpga_interchange/examples/tests/ram/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/ram/CMakeLists.txt
@@ -1,10 +1,8 @@
-add_interchange_test(
- name ram_basys3
+add_interchange_group_test(
+ name ram
family ${family}
- device xc7a35t
- package cpg236
+ board_list basys3
tcl run.tcl
- xdc basys3.xdc
sources ram.v
)