aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/tests
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-06-01 08:57:46 +0100
committergatecat <gatecat@ds0.me>2021-06-01 09:52:40 +0100
commit0426ba4e877c0ec1130d8ab7bc74e70cc4e406bf (patch)
treedd0776a3d57a596b15a3c6c52f7d203cb1094cc1 /fpga_interchange/examples/tests
parent24ae205f20f0e1a0326e48002ab14d5bacfca1ef (diff)
downloadnextpnr-0426ba4e877c0ec1130d8ab7bc74e70cc4e406bf.tar.gz
nextpnr-0426ba4e877c0ec1130d8ab7bc74e70cc4e406bf.tar.bz2
nextpnr-0426ba4e877c0ec1130d8ab7bc74e70cc4e406bf.zip
interchange: Add LIFCL-40 EVN tests
Signed-off-by: gatecat <gatecat@ds0.me>
Diffstat (limited to 'fpga_interchange/examples/tests')
-rw-r--r--fpga_interchange/examples/tests/counter/CMakeLists.txt2
-rw-r--r--fpga_interchange/examples/tests/counter/lifcl40evn.xdc13
-rw-r--r--fpga_interchange/examples/tests/lut_nexus/CMakeLists.txt11
-rw-r--r--fpga_interchange/examples/tests/wire/CMakeLists.txt9
-rw-r--r--fpga_interchange/examples/tests/wire/lifcl40evn.xdc5
-rw-r--r--fpga_interchange/examples/tests/wire/run_nexus.tcl14
6 files changed, 53 insertions, 1 deletions
diff --git a/fpga_interchange/examples/tests/counter/CMakeLists.txt b/fpga_interchange/examples/tests/counter/CMakeLists.txt
index 91929f93..2e0eefcc 100644
--- a/fpga_interchange/examples/tests/counter/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/counter/CMakeLists.txt
@@ -11,7 +11,7 @@ add_interchange_group_test(
add_interchange_group_test(
name counter
family ${family}
- board_list lifcl17
+ board_list lifcl17 lifcl40evn
tcl run_nexus.tcl
sources counter.v
techmap ../../remap_nexus.v
diff --git a/fpga_interchange/examples/tests/counter/lifcl40evn.xdc b/fpga_interchange/examples/tests/counter/lifcl40evn.xdc
new file mode 100644
index 00000000..4f378aef
--- /dev/null
+++ b/fpga_interchange/examples/tests/counter/lifcl40evn.xdc
@@ -0,0 +1,13 @@
+set_property PACKAGE_PIN L13 [get_ports clk]
+set_property PACKAGE_PIN G19 [get_ports rst]
+set_property PACKAGE_PIN E17 [get_ports io_led[4]]
+set_property PACKAGE_PIN F13 [get_ports io_led[5]]
+set_property PACKAGE_PIN G13 [get_ports io_led[6]]
+set_property PACKAGE_PIN F14 [get_ports io_led[7]]
+
+set_property IOSTANDARD LVCMOS33 [get_ports clk]
+set_property IOSTANDARD LVCMOS33 [get_ports rst]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[4]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[5]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[6]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[7]]
diff --git a/fpga_interchange/examples/tests/lut_nexus/CMakeLists.txt b/fpga_interchange/examples/tests/lut_nexus/CMakeLists.txt
index 1c65d87e..7ca36343 100644
--- a/fpga_interchange/examples/tests/lut_nexus/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/lut_nexus/CMakeLists.txt
@@ -8,3 +8,14 @@ add_interchange_test(
sources lut.v
skip_dcp
)
+
+add_interchange_test(
+ name lut_nexus40
+ family ${family}
+ device LIFCL-40
+ package CABGA400
+ tcl run.tcl
+ xdc empty.xdc
+ sources lut.v
+ skip_dcp
+)
diff --git a/fpga_interchange/examples/tests/wire/CMakeLists.txt b/fpga_interchange/examples/tests/wire/CMakeLists.txt
index 6308a6e9..9caffcd1 100644
--- a/fpga_interchange/examples/tests/wire/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/wire/CMakeLists.txt
@@ -6,3 +6,12 @@ add_interchange_group_test(
sources wire.v
output_fasm
)
+
+add_interchange_group_test(
+ name wire
+ family ${family}
+ board_list lifcl40evn
+ tcl run_nexus.tcl
+ sources wire.v
+ skip_dcp
+)
diff --git a/fpga_interchange/examples/tests/wire/lifcl40evn.xdc b/fpga_interchange/examples/tests/wire/lifcl40evn.xdc
new file mode 100644
index 00000000..c1a87488
--- /dev/null
+++ b/fpga_interchange/examples/tests/wire/lifcl40evn.xdc
@@ -0,0 +1,5 @@
+set_property PACKAGE_PIN G19 [get_ports i]
+set_property PACKAGE_PIN E17 [get_ports o]
+
+set_property IOSTANDARD LVCMOS33 [get_ports i]
+set_property IOSTANDARD LVCMOS33 [get_ports o]
diff --git a/fpga_interchange/examples/tests/wire/run_nexus.tcl b/fpga_interchange/examples/tests/wire/run_nexus.tcl
new file mode 100644
index 00000000..cddad3f8
--- /dev/null
+++ b/fpga_interchange/examples/tests/wire/run_nexus.tcl
@@ -0,0 +1,14 @@
+yosys -import
+
+read_verilog $::env(SOURCES)
+
+synth_nexus -nolutram -nowidelut -nobram -noccu2 -nodsp
+
+# opt_expr -undriven makes sure all nets are driven, if only by the $undef
+# net.
+opt_expr -undriven
+opt_clean
+
+setundef -zero -params
+
+write_json $::env(OUT_JSON)