aboutsummaryrefslogtreecommitdiffstats
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-29 08:18:15 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-29 08:18:15 +0200
commita4f69fba199a035dc017dbe1a998013e2fce9d64 (patch)
treee235b1208a2b2497b2f86bdabf04cfd781c47265 /gui/CMakeLists.txt
parent6e11c52dc933027ca5131bddf999953d1142edda (diff)
downloadnextpnr-a4f69fba199a035dc017dbe1a998013e2fce9d64.tar.gz
nextpnr-a4f69fba199a035dc017dbe1a998013e2fce9d64.tar.bz2
nextpnr-a4f69fba199a035dc017dbe1a998013e2fce9d64.zip
fix build without python
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt32
1 files changed, 19 insertions, 13 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index 2021b7ea..68fd0229 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -1,18 +1,20 @@
set(CMAKE_AUTOMOC ON)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-set(PYTHON_CONSOLE_SRC
- ../3rdparty/python-console/ColumnFormatter.cpp
- ../3rdparty/python-console/ParseHelper.cpp
- ../3rdparty/python-console/ParseHelper.BlockParseState.cpp
- ../3rdparty/python-console/ParseHelper.BracketParseState.cpp
- ../3rdparty/python-console/ParseHelper.ContinuationParseState.cpp
- ../3rdparty/python-console/ParseMessage.cpp
-
- ../3rdparty/python-console/modified/pyredirector.cc
- ../3rdparty/python-console/modified/pyinterpreter.cc
- ../3rdparty/python-console/modified/pyconsole.cc
-)
+if (BUILD_PYTHON)
+ set(PYTHON_CONSOLE_SRC
+ ../3rdparty/python-console/ColumnFormatter.cpp
+ ../3rdparty/python-console/ParseHelper.cpp
+ ../3rdparty/python-console/ParseHelper.BlockParseState.cpp
+ ../3rdparty/python-console/ParseHelper.BracketParseState.cpp
+ ../3rdparty/python-console/ParseHelper.ContinuationParseState.cpp
+ ../3rdparty/python-console/ParseMessage.cpp
+
+ ../3rdparty/python-console/modified/pyredirector.cc
+ ../3rdparty/python-console/modified/pyinterpreter.cc
+ ../3rdparty/python-console/modified/pyconsole.cc
+ )
+endif()
aux_source_directory(. GUI_SOURCE_FILES)
aux_source_directory(${family}/ GUI_SOURCE_FILES)
@@ -25,6 +27,10 @@ set(GUI_LIBRARY_FILES_${ufamily} Qt5::Widgets Qt5::OpenGL ${OPENGL_LIBRARIES} Qt
add_library(gui_${family} STATIC ${GUI_SOURCE_FILES} ${PYTHON_CONSOLE_SRC} ${GUI_RESOURCE_FILES})
-target_include_directories(gui_${family} PRIVATE ../${family} ${family} ../3rdparty/QtPropertyBrowser/src ../3rdparty/python-console ../3rdparty/python-console/modified)
+target_include_directories(gui_${family} PRIVATE ../${family} ${family} ../3rdparty/QtPropertyBrowser/src)
+if (BUILD_PYTHON)
+ target_include_directories(gui_${family} PRIVATE ../3rdparty/python-console ../3rdparty/python-console/modified)
+endif()
+
target_compile_definitions(gui_${family} PRIVATE NEXTPNR_NAMESPACE=nextpnr_${family} ARCH_${ufamily} ARCHNAME=${family} QT_NO_KEYWORDS)
target_link_libraries(gui_${family} Qt5::Widgets)