aboutsummaryrefslogtreecommitdiffstats
path: root/ice40
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2020-07-01 20:22:21 +0000
committerwhitequark <whitequark@whitequark.org>2020-07-01 20:22:21 +0000
commitf6e30f22f4334c36a42622e8fddd9cd92d0fe543 (patch)
tree224e63f2e2bea8c0e78284b563057dd205d36557 /ice40
parentc0901fb972e34d2d16b3ac0074a18542ba1c448d (diff)
downloadnextpnr-f6e30f22f4334c36a42622e8fddd9cd92d0fe543.tar.gz
nextpnr-f6e30f22f4334c36a42622e8fddd9cd92d0fe543.tar.bz2
nextpnr-f6e30f22f4334c36a42622e8fddd9cd92d0fe543.zip
CMake: fix path checks in chipdb build scripts.
`if(NOT DEFINED)` is not appropriate since a variable that contains `-NOTFOUND` still counts as `DEFINED`. This can cause issues if configuration fails, writes `-NOTFOUND` to the cache, and is then restarted.
Diffstat (limited to 'ice40')
-rw-r--r--ice40/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/ice40/CMakeLists.txt b/ice40/CMakeLists.txt
index 1bf64905..89203bbc 100644
--- a/ice40/CMakeLists.txt
+++ b/ice40/CMakeLists.txt
@@ -27,7 +27,7 @@ else()
"IceStorm install prefix")
message(STATUS "IceStorm install prefix: ${ICESTORM_INSTALL_PREFIX}")
- if(NOT DEFINED ICEBOX_DATADIR)
+ if(NOT ICEBOX_DATADIR)
set(ICEBOX_DATADIR ${ICESTORM_INSTALL_PREFIX}/share/icebox)
endif()
message(STATUS "icebox data directory: ${ICEBOX_DATADIR}")