aboutsummaryrefslogtreecommitdiffstats
path: root/machxo2/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2023-03-10 15:29:59 +0100
committermyrtle <gatecat@ds0.me>2023-03-16 13:37:23 +0100
commit6eb5f2a77e23a89d0876dd041ebe5871ff6b65ce (patch)
tree5ee6a66944735872dea3569158aae12e7133cb00 /machxo2/CMakeLists.txt
parent1f115ddd320dc5e2f9c69e32ee2e40b758285f6e (diff)
downloadnextpnr-6eb5f2a77e23a89d0876dd041ebe5871ff6b65ce.tar.gz
nextpnr-6eb5f2a77e23a89d0876dd041ebe5871ff6b65ce.tar.bz2
nextpnr-6eb5f2a77e23a89d0876dd041ebe5871ff6b65ce.zip
Enable wires and add dummy wire type for now
Diffstat (limited to 'machxo2/CMakeLists.txt')
-rw-r--r--machxo2/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/machxo2/CMakeLists.txt b/machxo2/CMakeLists.txt
index 4d54f2fa..414c6571 100644
--- a/machxo2/CMakeLists.txt
+++ b/machxo2/CMakeLists.txt
@@ -62,6 +62,7 @@ else()
-L ${TRELLIS_DATADIR}/util/common
-L ${TRELLIS_DATADIR}/timing/util
-p ${CMAKE_CURRENT_SOURCE_DIR}/constids.inc
+ -g ${CMAKE_CURRENT_SOURCE_DIR}/gfx.h
${device}
> ${device_bba}.new
# atomically update
@@ -69,6 +70,7 @@ else()
DEPENDS
${CMAKE_CURRENT_SOURCE_DIR}/facade_import.py
${CMAKE_CURRENT_SOURCE_DIR}/constids.inc
+ ${CMAKE_CURRENT_SOURCE_DIR}/gfx.h
${PREVIOUS_CHIPDB_TARGET}
VERBATIM)
list(APPEND all_device_bbas ${device_bba})