aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/QtPropertyBrowser/examples/extension/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/QtPropertyBrowser/examples/extension/CMakeLists.txt')
-rw-r--r--3rdparty/QtPropertyBrowser/examples/extension/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/3rdparty/QtPropertyBrowser/examples/extension/CMakeLists.txt b/3rdparty/QtPropertyBrowser/examples/extension/CMakeLists.txt
new file mode 100644
index 00000000..25d6b9cf
--- /dev/null
+++ b/3rdparty/QtPropertyBrowser/examples/extension/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Tell CMake to run moc when necessary:
+set(CMAKE_AUTOMOC ON)
+
+# As moc files are generated in the binary dir, tell CMake
+# to always look for includes there:
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+SET(example_name extension)
+
+SET(KIT_SRCS
+ main.cpp
+ )
+
+ADD_EXECUTABLE(${example_name} ${KIT_SRCS})
+TARGET_LINK_LIBRARIES(${example_name} ${PROJECT_NAME}) \ No newline at end of file