aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/imgui/examples/example_glfw_vulkan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/imgui/examples/example_glfw_vulkan/CMakeLists.txt')
-rw-r--r--3rdparty/imgui/examples/example_glfw_vulkan/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/3rdparty/imgui/examples/example_glfw_vulkan/CMakeLists.txt b/3rdparty/imgui/examples/example_glfw_vulkan/CMakeLists.txt
new file mode 100644
index 00000000..82d7ab47
--- /dev/null
+++ b/3rdparty/imgui/examples/example_glfw_vulkan/CMakeLists.txt
@@ -0,0 +1,36 @@
+cmake_minimum_required(VERSION 2.8)
+project(imgui_example_glfw_vulkan C CXX)
+
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Debug CACHE STRING "" FORCE)
+endif()
+
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DVK_PROTOTYPES")
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DVK_PROTOTYPES")
+
+# GLFW
+set(GLFW_DIR ../../../glfw) # Set this to point to an up-to-date GLFW repo
+option(GLFW_BUILD_EXAMPLES "Build the GLFW example programs" OFF)
+option(GLFW_BUILD_TESTS "Build the GLFW test programs" OFF)
+option(GLFW_BUILD_DOCS "Build the GLFW documentation" OFF)
+option(GLFW_INSTALL "Generate installation target" OFF)
+option(GLFW_DOCUMENT_INTERNALS "Include internals in documentation" OFF)
+add_subdirectory(${GLFW_DIR} binary_dir EXCLUDE_FROM_ALL)
+include_directories(${GLFW_DIR}/include)
+
+# ImGui
+set(IMGUI_DIR ../../)
+include_directories(${IMGUI_DIR} ..)
+
+# Libraries
+find_library(VULKAN_LIBRARY
+ NAMES vulkan vulkan-1)
+set(LIBRARIES "glfw;${VULKAN_LIBRARY}")
+
+# Use vulkan headers from glfw:
+include_directories(${GLFW_DIR}/deps)
+
+file(GLOB sources *.cpp)
+
+add_executable(example_glfw_vulkan ${sources} ${IMGUI_DIR}/examples/imgui_impl_glfw.cpp ${IMGUI_DIR}/examples/imgui_impl_vulkan.cpp ${IMGUI_DIR}/imgui.cpp ${IMGUI_DIR}/imgui_draw.cpp ${IMGUI_DIR}/imgui_demo.cpp ${IMGUI_DIR}/imgui_widgets.cpp)
+target_link_libraries(example_glfw_vulkan ${LIBRARIES})