aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/pybind11/docs/release.rst
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/pybind11/docs/release.rst')
-rw-r--r--3rdparty/pybind11/docs/release.rst21
1 files changed, 21 insertions, 0 deletions
diff --git a/3rdparty/pybind11/docs/release.rst b/3rdparty/pybind11/docs/release.rst
new file mode 100644
index 00000000..9846f971
--- /dev/null
+++ b/3rdparty/pybind11/docs/release.rst
@@ -0,0 +1,21 @@
+To release a new version of pybind11:
+
+- Update the version number and push to pypi
+ - Update ``pybind11/_version.py`` (set release version, remove 'dev').
+ - Update ``PYBIND11_VERSION_MAJOR`` etc. in ``include/pybind11/detail/common.h``.
+ - Ensure that all the information in ``setup.py`` is up-to-date.
+ - Update version in ``docs/conf.py``.
+ - Tag release date in ``docs/changelog.rst``.
+ - ``git add`` and ``git commit``.
+ - if new minor version: ``git checkout -b vX.Y``, ``git push -u origin vX.Y``
+ - ``git tag -a vX.Y.Z -m 'vX.Y.Z release'``.
+ - ``git push``
+ - ``git push --tags``.
+ - ``python setup.py sdist upload``.
+ - ``python setup.py bdist_wheel upload``.
+- Get back to work
+ - Update ``_version.py`` (add 'dev' and increment minor).
+ - Update version in ``docs/conf.py``
+ - Update version macros in ``include/pybind11/common.h``
+ - ``git add`` and ``git commit``.
+ ``git push``