aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/pybind11/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/pybind11/setup.cfg')
-rw-r--r--3rdparty/pybind11/setup.cfg49
1 files changed, 14 insertions, 35 deletions
diff --git a/3rdparty/pybind11/setup.cfg b/3rdparty/pybind11/setup.cfg
index e7fc8f4d..9af50ea4 100644
--- a/3rdparty/pybind11/setup.cfg
+++ b/3rdparty/pybind11/setup.cfg
@@ -13,13 +13,13 @@ classifiers =
Topic :: Software Development :: Libraries :: Python Modules
Topic :: Utilities
Programming Language :: C++
- Programming Language :: Python :: 2.7
- Programming Language :: Python :: 3
- Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
+ Programming Language :: Python :: 3.11
License :: OSI Approved :: BSD License
Programming Language :: Python :: Implementation :: PyPy
Programming Language :: Python :: Implementation :: CPython
@@ -30,42 +30,21 @@ keywords =
C++11
Python bindings
+project_urls =
+ Documentation = https://pybind11.readthedocs.io/
+ Bug Tracker = https://github.com/pybind/pybind11/issues
+ Discussions = https://github.com/pybind/pybind11/discussions
+ Changelog = https://pybind11.readthedocs.io/en/latest/changelog.html
+ Chat = https://gitter.im/pybind/Lobby
+
[options]
-python_requires = >=2.7, !=3.0, !=3.1, !=3.2, !=3.3, !=3.4
+python_requires = >=3.6
zip_safe = False
-[bdist_wheel]
-universal=1
-
-[check-manifest]
-ignore =
- tests/**
- docs/**
- tools/**
- include/**
- .appveyor.yml
- .cmake-format.yaml
- .gitmodules
- .pre-commit-config.yaml
- .readthedocs.yml
- .clang-tidy
- pybind11/include/**
- pybind11/share/**
- CMakeLists.txt
-
[flake8]
-max-line-length = 99
+max-line-length = 120
show_source = True
exclude = .git, __pycache__, build, dist, docs, tools, venv
-ignore =
- # required for pretty matrix formatting: multiple spaces after `,` and `[`
- E201, E241, W504,
- # camelcase 'cPickle' imported as lowercase 'pickle'
- N813
- # Black conflict
- W503, E203
-
-[mypy]
-files = pybind11
-strict = True
+extend-ignore = E203, E722, B903, B950
+extend-select = B9