aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b50e1d8..dfc33e90 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,8 +70,10 @@ if (NOT Boost_PYTHON_FOUND )
endif ()
include(gui/gui.cmake)
-include_directories(common/ gui/ ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
-aux_source_directory(common/ COMMON_FILES)
+include_directories(common/ gui/ frontend/json ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+aux_source_directory(common/ COMMON_SRC_FILES)
+aux_source_directory(frontend/json/ JSON_PARSER_FILES)
+set(COMMON_FILES ${COMMON_SRC_FILES} ${JSON_PARSER_FILES})
foreach (family ${FAMILIES})
string(TOUPPER ${family} ufamily)