aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7159efd4..ff26d4ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,10 @@ if(WASI)
)
else()
set(USE_THREADS ON)
+ find_package(TBB QUIET)
+ if (TBB_FOUND)
+ add_definitions(-DNEXTPNR_USE_TBB)
+ endif()
endif()
if (NOT USE_THREADS)
@@ -243,6 +247,9 @@ endif()
if(PROFILER)
list(APPEND EXTRA_LIB_DEPS profiler)
endif()
+if(TBB_FOUND)
+ list(APPEND EXTRA_LIB_DEPS tbb)
+endif()
foreach (family ${ARCH})
message(STATUS "Configuring architecture: ${family}")