aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3df6a58..6ebc2e75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,7 +171,9 @@ if (NOT DEFINED CURRENT_GIT_VERSION)
)
endif()
-add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
+if (NOT WASI)
+ add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
+endif()
if (BUILD_TESTS)
add_subdirectory(3rdparty/googletest/googletest ${CMAKE_CURRENT_BINARY_DIR}/generated/3rdparty/googletest EXCLUDE_FROM_ALL)