aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55e57763..cc712e72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,8 +191,12 @@ foreach (family ${ARCH})
# Add any new per-architecture targets here
if (BUILD_TESTS)
aux_source_directory(tests/${family}/ ${ufamily}_TEST_FILES)
+ if (BUILD_GUI)
+ aux_source_directory(tests/gui/ GUI_TEST_FILES)
+ endif()
- add_executable(nextpnr-${family}-test ${${ufamily}_TEST_FILES} ${COMMON_FILES} ${${ufamily}_FILES})
+ add_executable(nextpnr-${family}-test ${${ufamily}_TEST_FILES}
+ ${COMMON_FILES} ${${ufamily}_FILES} ${GUI_TEST_FILES})
target_link_libraries(nextpnr-${family}-test PRIVATE gtest_main)
add_sanitizers(nextpnr-${family}-test)