aboutsummaryrefslogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'README.md')
-rw-r--r--README.md3
1 files changed, 3 insertions, 0 deletions
diff --git a/README.md b/README.md
index 195f08c3..7fe49328 100644
--- a/README.md
+++ b/README.md
@@ -27,6 +27,9 @@ Prequisites
Building
--------
+ - Specifying target architecture is mandatory use ARCH parameter to set it. It is semicolon separated list.
+ - Use `cmake . -DARCH=all` to build all supported targets
+ - For example `cmake . -DARCH=ice40` would build just ICE40 support
- Use CMake to generate the Makefiles (only needs to be done when `CMakeLists.txt` changes)
- For a debug build, run `cmake -DCMAKE_BUILD_TYPE=Debug .`
- For a debug build with HX1K support only, run ` cmake -DCMAKE_BUILD_TYPE=Debug -DICE40_HX1K_ONLY=1 .`