aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/archcheck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fpga_interchange/examples/archcheck/Makefile')
-rw-r--r--fpga_interchange/examples/archcheck/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/fpga_interchange/examples/archcheck/Makefile b/fpga_interchange/examples/archcheck/Makefile
new file mode 100644
index 00000000..8984e1b4
--- /dev/null
+++ b/fpga_interchange/examples/archcheck/Makefile
@@ -0,0 +1,16 @@
+NEXTPNR_PATH := $(shell echo ~/cat_x/nextpnr)
+NEXTPNR_BIN := $(NEXTPNR_PATH)/build/nextpnr-fpga_interchange
+BBA_PATH := $(NEXTPNR_PATH)/build/test.bin
+
+PACKAGE := csg324
+
+.PHONY:
+
+check:
+ $(NEXTPNR_BIN) \
+ --chipdb $(BBA_PATH) \
+ --package $(PACKAGE) \
+ --test
+ $(NEXTPNR_BIN) \
+ --chipdb $(BBA_PATH) \
+ --run $(NEXTPNR_PATH)/python/check_arch_api.py