aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2017-07-03 19:33:25 +0200
committerGitHub <noreply@github.com>2017-07-03 19:33:25 +0200
commit3f863c607a94d878ebe36642a645207ba46522de (patch)
tree49e5f54e7f933541e31e47176e6803c66288aed0
parentd223292aa9daf5cce6790bd5ee688839a7149c85 (diff)
parentfb3051104478bbb06a3fd13fc8c68ed7a5b228b4 (diff)
downloadyosys-3f863c607a94d878ebe36642a645207ba46522de.tar.gz
yosys-3f863c607a94d878ebe36642a645207ba46522de.tar.bz2
yosys-3f863c607a94d878ebe36642a645207ba46522de.zip
Merge pull request #356 from set-soft/clean-test
Added the test outputs to the clean target
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2868ba1e5..ffb5db823 100644
--- a/Makefile
+++ b/Makefile
@@ -504,6 +504,14 @@ clean:
rm -f $(OBJS) $(GENFILES) $(TARGETS) $(EXTRA_TARGETS) $(EXTRA_OBJS)
rm -f kernel/version_*.o kernel/version_*.cc abc/abc-[0-9a-f]*
rm -f libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d techlibs/*/*.d
+ rm -rf tests/asicworld/*.out tests/asicworld/*.log
+ rm -rf tests/hana/*.out tests/hana/*.log
+ rm -rf tests/simple/*.out tests/simple/*.log
+ rm -rf tests/memories/*.out tests/memories/*.log tests/memories/*.dmp
+ rm -rf tests/sat/*.log tests/techmap/*.log tests/various/*.log
+ rm -rf tests/bram/temp tests/fsm/temp tests/realmath/temp tests/share/temp tests/smv/temp
+ rm -rf vloghtb/Makefile vloghtb/refdat vloghtb/rtl vloghtb/scripts vloghtb/spec vloghtb/check_yosys vloghtb/vloghammer_tb.tar.bz2 vloghtb/temp vloghtb/log_test_*
+ rm -f tests/tools/cmp_tbdata
clean-abc:
$(MAKE) -C abc DEP= clean