aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArjen Roodselaar <arjen@fb.com>2018-11-07 23:18:47 -0800
committerArjen Roodselaar <arjen@fb.com>2018-11-07 23:18:47 -0800
commit4e846694f76d48f77b44a109d8ed478c8071ebd6 (patch)
tree72a6af7346eaaecfbb3fcd0c9ae541e9a632036a
parent825b4c1aa9ae5abe7484f056cc14d973bcaae378 (diff)
downloadyosys-4e846694f76d48f77b44a109d8ed478c8071ebd6.tar.gz
yosys-4e846694f76d48f77b44a109d8ed478c8071ebd6.tar.bz2
yosys-4e846694f76d48f77b44a109d8ed478c8071ebd6.zip
Use appropriate static libraries when building with Verific on MacOS
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index fd708b7de..cb9880754 100644
--- a/Makefile
+++ b/Makefile
@@ -359,8 +359,12 @@ ifeq ($(ENABLE_VERIFIC),1)
VERIFIC_DIR ?= /usr/local/src/verific_lib_eval
VERIFIC_COMPONENTS ?= verilog vhdl database util containers sdf hier_tree
CXXFLAGS += $(patsubst %,-I$(VERIFIC_DIR)/%,$(VERIFIC_COMPONENTS)) -DYOSYS_ENABLE_VERIFIC
+ifeq ($(OS), Darwin)
+LDLIBS += $(patsubst %,$(VERIFIC_DIR)/%/*-mac.a,$(VERIFIC_COMPONENTS)) -lz
+else
LDLIBS += $(patsubst %,$(VERIFIC_DIR)/%/*-linux.a,$(VERIFIC_COMPONENTS)) -lz
endif
+endif
ifeq ($(ENABLE_PROTOBUF),1)
LDLIBS += $(shell pkg-config --cflags --libs protobuf)