aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEddie Hung <eddie@fpgeh.com>2019-08-28 18:50:20 -0700
committerEddie Hung <eddie@fpgeh.com>2019-08-28 18:50:20 -0700
commit5c42455350740cbdc8f12ba912eb32398c61e9fb (patch)
tree6baabf587a4b68c60d65911796dd20ba78811d5f
parentc0b99ed0e8c8c6adf76d70fa71c9753957162e04 (diff)
parent13ecd8b0df267285eb9f0a6fda84684ef491eded (diff)
downloadyosys-5c42455350740cbdc8f12ba912eb32398c61e9fb.tar.gz
yosys-5c42455350740cbdc8f12ba912eb32398c61e9fb.tar.bz2
yosys-5c42455350740cbdc8f12ba912eb32398c61e9fb.zip
Merge remote-tracking branch 'origin/eddie/fix_carry_wrapper' into xaig_arrival
-rwxr-xr-xtests/ice40/run-test.sh20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/ice40/run-test.sh b/tests/ice40/run-test.sh
new file mode 100755
index 000000000..ea56b70f0
--- /dev/null
+++ b/tests/ice40/run-test.sh
@@ -0,0 +1,20 @@
+#!/usr/bin/env bash
+set -e
+{
+echo "all::"
+for x in *.ys; do
+ echo "all:: run-$x"
+ echo "run-$x:"
+ echo " @echo 'Running $x..'"
+ echo " @../../yosys -ql ${x%.ys}.log $x"
+done
+for s in *.sh; do
+ if [ "$s" != "run-test.sh" ]; then
+ echo "all:: run-$s"
+ echo "run-$s:"
+ echo " @echo 'Running $s..'"
+ echo " @bash $s"
+ fi
+done
+} > run-test.mk
+exec ${MAKE:-make} -f run-test.mk