aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenedikt Tutzer <benedikt.tutzer@gmail.com>2020-09-25 11:21:16 +0200
committerBenedikt Tutzer <benedikt.tutzer@gmail.com>2020-09-25 11:21:16 +0200
commit9266d20afc7f3571ffee5edc27afe19dc54bb356 (patch)
tree78e02c23bf3002aa0a05f895351b9f2e75d140cb
parentcd8b2ed4e6f9447c94d801de7db7ae6ce0976d57 (diff)
downloadyosys-9266d20afc7f3571ffee5edc27afe19dc54bb356.tar.gz
yosys-9266d20afc7f3571ffee5edc27afe19dc54bb356.tar.bz2
yosys-9266d20afc7f3571ffee5edc27afe19dc54bb356.zip
Fixed python installation path
The path where python expects it's libraries seems to change from operating system to operating system, but can be querried from the site package.
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a3ff10625..329ad75eb 100644
--- a/Makefile
+++ b/Makefile
@@ -171,8 +171,7 @@ else
PYTHON_CONFIG := $(PYTHON_EXECUTABLE)-config
endif
-PYTHON_PREFIX := $(shell $(PYTHON_CONFIG) --prefix)
-PYTHON_DESTDIR := $(PYTHON_PREFIX)/lib/python$(PYTHON_VERSION)/site-packages
+PYTHON_DESTDIR := $(shell $(PYTHON_EXECUTABLE) -c "import site; print(site.getsitepackages()[-1]);")
# Reload Makefile.conf to override python specific variables if defined
ifneq ($(wildcard Makefile.conf),)