aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Vogel <post@steffenvogel.de>2017-02-10 10:04:42 -0300
committerSteffen Vogel <post@steffenvogel.de>2017-02-10 10:04:42 -0300
commit9eca3671abe054e973b6c38c6670b0053954b4c2 (patch)
tree37a88b488dc39c95040cdd148072fbfb5675796d
parenta3f19f047c4f6fa659bfbb04524ffa42804a5d26 (diff)
downloadyosys-9eca3671abe054e973b6c38c6670b0053954b4c2.tar.gz
yosys-9eca3671abe054e973b6c38c6670b0053954b4c2.tar.bz2
yosys-9eca3671abe054e973b6c38c6670b0053954b4c2.zip
Dont mix Homebrew and MacPorts build options
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 50dc1b865..1a430277f 100644
--- a/Makefile
+++ b/Makefile
@@ -73,10 +73,9 @@ LDFLAGS += -L$(BREW_PREFIX)/readline/lib
PKG_CONFIG_PATH := $(BREW_PREFIX)/libffi/lib/pkgconfig:$(PKG_CONFIG_PATH)
export PATH := $(BREW_PREFIX)/bison/bin:$(BREW_PREFIX)/gettext/bin:$(BREW_PREFIX)/flex/bin:$(PATH)
-endif
# macports search paths
-ifneq ($(shell which port),)
+else ifneq ($(shell which port),)
PORT_PREFIX := $(patsubst %/bin/port,%,$(shell which port))
CXXFLAGS += -I$(PORT_PREFIX)/include