aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorumarcor <unai.martinezcorral@ehu.eus>2020-12-28 02:24:41 +0100
committerumarcor <unai.martinezcorral@ehu.eus>2020-12-28 22:45:00 +0100
commita652430c711b831423bfd2a2c0c20caa2fc333c8 (patch)
tree1c03f868fa9c42bfa9c35530ac7d7cf358359107
parentc718780ff6a152d80a9c5d15c17b32bede513ab8 (diff)
downloadyosys-a652430c711b831423bfd2a2c0c20caa2fc333c8.tar.gz
yosys-a652430c711b831423bfd2a2c0c20caa2fc333c8.tar.bz2
yosys-a652430c711b831423bfd2a2c0c20caa2fc333c8.zip
makefile: add support for built-in ghdl-yosys-plugin
Co-authored-by: Tristan Gingold <tgingold@free.fr> Co-authored-by: whitequark <whitequark@whitequark.org>
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 57bf2a726..76018a014 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,7 @@ ENABLE_GLOB := 1
ENABLE_PLUGINS := 1
ENABLE_READLINE := 1
ENABLE_EDITLINE := 0
+ENABLE_GHDL := 0
ENABLE_VERIFIC := 0
ENABLE_COVER := 1
ENABLE_LIBYOSYS := 0
@@ -511,6 +512,14 @@ endif
endif
endif
+ifeq ($(ENABLE_GHDL),1)
+GHDL_PREFIX ?= $(PREFIX)
+GHDL_INCLUDE_DIR ?= $(GHDL_DIR)/include
+GHDL_LIB_DIR ?= $(GHDL_DIR)/lib
+CXXFLAGS += -I$(GHDL_INCLUDE_DIR) -DYOSYS_ENABLE_GHDL
+LDLIBS += $(GHDL_LIB_DIR)/libghdl.a $(file <$(GHDL_LIB_DIR)/libghdl.link)
+endif
+
ifeq ($(ENABLE_VERIFIC),1)
VERIFIC_DIR ?= /usr/local/src/verific_lib
VERIFIC_COMPONENTS ?= verilog vhdl database util containers hier_tree