diff options
author | Eddie Hung <eddie@fpgeh.com> | 2020-05-11 10:30:20 -0700 |
---|---|---|
committer | Eddie Hung <eddie@fpgeh.com> | 2020-05-11 10:31:02 -0700 |
commit | b11cf67a8170ee830beedadc7156c4e83e4f1134 (patch) | |
tree | 77992ff8a98d1d320519ade7f5106053283976a4 | |
parent | aafaeb66dfd839b8223059884d2741dadc9e2d92 (diff) | |
download | yosys-b11cf67a8170ee830beedadc7156c4e83e4f1134.tar.gz yosys-b11cf67a8170ee830beedadc7156c4e83e4f1134.tar.bz2 yosys-b11cf67a8170ee830beedadc7156c4e83e4f1134.zip |
Setup tests/verilog properly
-rw-r--r-- | Makefile | 1 | ||||
-rw-r--r-- | tests/verilog/.gitignore | 3 | ||||
-rwxr-xr-x | tests/verilog/run-test.sh | 20 |
3 files changed, 24 insertions, 0 deletions
@@ -780,6 +780,7 @@ test: $(TARGETS) $(EXTRA_TARGETS) +cd tests/arch/intel_alm && bash run-test.sh $(SEEDOPT) +cd tests/rpc && bash run-test.sh +cd tests/memfile && bash run-test.sh + +cd tests/verilog && bash run-test.sh @echo "" @echo " Passed \"make test\"." @echo "" diff --git a/tests/verilog/.gitignore b/tests/verilog/.gitignore new file mode 100644 index 000000000..b48f808a1 --- /dev/null +++ b/tests/verilog/.gitignore @@ -0,0 +1,3 @@ +/*.log +/*.out +/run-test.mk diff --git a/tests/verilog/run-test.sh b/tests/verilog/run-test.sh new file mode 100755 index 000000000..ea56b70f0 --- /dev/null +++ b/tests/verilog/run-test.sh @@ -0,0 +1,20 @@ +#!/usr/bin/env bash +set -e +{ +echo "all::" +for x in *.ys; do + echo "all:: run-$x" + echo "run-$x:" + echo " @echo 'Running $x..'" + echo " @../../yosys -ql ${x%.ys}.log $x" +done +for s in *.sh; do + if [ "$s" != "run-test.sh" ]; then + echo "all:: run-$s" + echo "run-$s:" + echo " @echo 'Running $s..'" + echo " @bash $s" + fi +done +} > run-test.mk +exec ${MAKE:-make} -f run-test.mk |