aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclairexen <claire@symbioticeda.com>2020-06-04 18:23:33 +0200
committerGitHub <noreply@github.com>2020-06-04 18:23:33 +0200
commitba99c0ea8140131a95ed3d5467c5b2c93d16552e (patch)
treed1089d4f2aeb11bc46ecc00e72c6199e4d50c156
parentd8d8deeaf4fe576ca419560ae882771116279c67 (diff)
parent8b0ec3c3a24108d7d3bf42e05effd561d10a918b (diff)
downloadyosys-ba99c0ea8140131a95ed3d5467c5b2c93d16552e.tar.gz
yosys-ba99c0ea8140131a95ed3d5467c5b2c93d16552e.tar.bz2
yosys-ba99c0ea8140131a95ed3d5467c5b2c93d16552e.zip
Merge pull request #2099 from Xiretza/manual-include-path
Use in-tree include directory in manual build
-rw-r--r--manual/PRESENTATION_Prog/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/manual/PRESENTATION_Prog/Makefile b/manual/PRESENTATION_Prog/Makefile
index 794f5c12c..7e3cf814b 100644
--- a/manual/PRESENTATION_Prog/Makefile
+++ b/manual/PRESENTATION_Prog/Makefile
@@ -1,8 +1,11 @@
all: test0.log test1.log test2.log
+CXXFLAGS=$(shell ../../yosys-config --cxxflags)
+DATDIR=$(shell ../../yosys-config --datdir)
+
my_cmd.so: my_cmd.cc
- ../../yosys-config --exec --cxx --cxxflags --ldflags -o my_cmd.so -shared my_cmd.cc --ldlibs
+ ../../yosys-config --exec --cxx $(subst $(DATDIR),../../share,$(CXXFLAGS)) --ldflags -o my_cmd.so -shared my_cmd.cc --ldlibs
test0.log: my_cmd.so
../../yosys -Ql test0.log_new -m ./my_cmd.so -p 'my_cmd foo bar' absval_ref.v