aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2017-07-18 15:21:12 +0200
committerGitHub <noreply@github.com>2017-07-18 15:21:12 +0200
commitdbb2f755c1150b45cce5870530d0d1e2be80f519 (patch)
tree31cdb36bab91235038d2501f6dec856325d7e30d
parentc00d8a5b73306b6fd02471382b25cc3dd321a2fc (diff)
parent85d667ca08d53c4869c8212bd79155422941aa2d (diff)
downloadyosys-dbb2f755c1150b45cce5870530d0d1e2be80f519.tar.gz
yosys-dbb2f755c1150b45cce5870530d0d1e2be80f519.tar.bz2
yosys-dbb2f755c1150b45cce5870530d0d1e2be80f519.zip
Merge pull request #363 from rqou/master
Miscellaneous build tweaks
-rw-r--r--Makefile5
-rw-r--r--kernel/hashlib.h2
2 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ffb5db823..81d718430 100644
--- a/Makefile
+++ b/Makefile
@@ -19,6 +19,7 @@ ENABLE_LIBYOSYS := 0
ENABLE_GPROF := 0
ENABLE_NDEBUG := 0
LINK_CURSES := 0
+LINK_TERMCAP := 0
# clang sanitizers
SANITIZER =
@@ -213,6 +214,10 @@ ifeq ($(LINK_CURSES),1)
LDLIBS += -lcurses
ABCMKARGS += "ABC_READLINE_LIBRARIES=-lcurses -lreadline"
endif
+ifeq ($(LINK_TERMCAP),1)
+LDLIBS += -ltermcap
+ABCMKARGS += "ABC_READLINE_LIBRARIES=-lreadline -ltermcap"
+endif
ifeq ($(CONFIG),mxe)
LDLIBS += -ltermcap
endif
diff --git a/kernel/hashlib.h b/kernel/hashlib.h
index 3c824b8c3..4199e6f3a 100644
--- a/kernel/hashlib.h
+++ b/kernel/hashlib.h
@@ -147,7 +147,7 @@ struct hash_ptr_ops {
return a == b;
}
static inline unsigned int hash(const void *a) {
- return (unsigned long)a;
+ return (intptr_t)a;
}
};