aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2013-11-04 04:35:35 -0800
committerClifford Wolf <clifford@clifford.at>2013-11-04 04:35:35 -0800
commitf830666ec02a59eefa4547dfb633bc9b7b40d8f5 (patch)
tree03d78dbe3599f6c6561b8a12f1052995877364a6
parentba305a7ca6f5d380d4cb2ead12c5bed5444b8423 (diff)
parent58cfce6c5af48748e17e390ca190f2cf5426db32 (diff)
downloadyosys-f830666ec02a59eefa4547dfb633bc9b7b40d8f5.tar.gz
yosys-f830666ec02a59eefa4547dfb633bc9b7b40d8f5.tar.bz2
yosys-f830666ec02a59eefa4547dfb633bc9b7b40d8f5.zip
Merge pull request #16 from mschmoelzer/master
Allow setting of installation destination via DESTDIR variable in Makefi...
-rw-r--r--Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 312225ef1..c11f84f55 100644
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,8 @@ ENABLE_QT4 := 1
ENABLE_MINISAT := 1
ENABLE_GPROF := 0
+DESTDIR = "/usr/local"
+
OBJS =
GENFILES =
EXTRA_TARGETS =
@@ -105,12 +107,13 @@ test: yosys
cd tests/asicworld && bash run-test.sh
install: $(TARGETS)
- install $(TARGETS) /usr/local/bin/
- mkdir -p /usr/local/share/yosys
- cp -r share/. /usr/local/share/yosys/.
+ mkdir -p $(DESTDIR)/bin
+ install $(TARGETS) $(DESTDIR)/bin/
+ mkdir -p $(DESTDIR)/share/yosys
+ cp -r share/. $(DESTDIR)/share/yosys/.
install-abc:
- install yosys-abc /usr/local/bin/
+ install yosys-abc $(DESTDIR)/bin/
manual:
cd manual && bash make.sh