aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Headapohl <joshhead@gmail.com>2017-02-23 20:21:03 -0500
committerJosh Headapohl <joshhead@gmail.com>2017-02-23 20:21:03 -0500
commitfde9fdfbe847afa6b795720689074b0a9d3e43b7 (patch)
tree6cf88e7fbc78158c899658fc37f4896bcc25b8d3
parent00dba4c197b7e3b6c1d1f7b90ae7b1e6172b1e5f (diff)
downloadyosys-fde9fdfbe847afa6b795720689074b0a9d3e43b7.tar.gz
yosys-fde9fdfbe847afa6b795720689074b0a9d3e43b7.tar.bz2
yosys-fde9fdfbe847afa6b795720689074b0a9d3e43b7.zip
Add missing slashes in paths for make uninstall
Running make uninstall used to fail to remove binaries: rm -vf /usr/local/binyosys /usr/local/binyosys-config #...etc Fix Makefile so that it runs a command like this: rm -vf /usr/local/bin/yosys /usr/local/bin/yosys-config #...etc
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a6779334e..e779cf20d 100644
--- a/Makefile
+++ b/Makefile
@@ -478,7 +478,7 @@ ifeq ($(ENABLE_LIBYOSYS),1)
endif
uninstall:
- $(INSTALL_SUDO) rm -vf $(addprefix $(DESTDIR)$(BINDIR),$(notdir $(TARGETS)))
+ $(INSTALL_SUDO) rm -vf $(addprefix $(DESTDIR)$(BINDIR)/,$(notdir $(TARGETS)))
$(INSTALL_SUDO) rm -rvf $(DESTDIR)$(DATDIR)
ifeq ($(ENABLE_LIBYOSYS),1)
$(INSTALL_SUDO) rm -vf $(DESTDIR)$(LIBDIR)/libyosys.so