diff options
author | Clifford Wolf <clifford@clifford.at> | 2014-07-24 17:55:55 +0200 |
---|---|---|
committer | Clifford Wolf <clifford@clifford.at> | 2014-07-24 17:55:55 +0200 |
commit | 34ea9e3f098925a7e107f2da265ff27b6b9985be (patch) | |
tree | 57a4694e24d12f972bd5db1476e2f8773d39a26e /Makefile | |
parent | 38afbe62ef61bd9b1aa92575cad7ff1785ce5e0e (diff) | |
download | yosys-34ea9e3f098925a7e107f2da265ff27b6b9985be.tar.gz yosys-34ea9e3f098925a7e107f2da265ff27b6b9985be.tar.bz2 yosys-34ea9e3f098925a7e107f2da265ff27b6b9985be.zip |
Now "make PRETTY=1" is the default setting
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 12 |
1 files changed, 7 insertions, 5 deletions
@@ -21,6 +21,8 @@ GENFILES = EXTRA_TARGETS = TARGETS = yosys yosys-config +PRETTY = 1 + all: top-all CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -MD -DYOSYS_SRC='"$(shell pwd)"' -D_YOSYS_ -fPIC -I${DESTDIR}/include @@ -44,11 +46,6 @@ YOSYS_VER := 0.3.0+ GIT_REV := $(shell git rev-parse --short HEAD || echo UNKOWN) OBJS = kernel/version_$(GIT_REV).o -PRETTY = 0 -P = -Q = -S = - # set 'ABCREV = default' to use abc/ as it is # # Note: If you do ABC development, make sure that 'abc' in this directory @@ -113,6 +110,11 @@ P = @echo "$(eval I=$(shell bash -c 'i=0; for x in $(OBJS) yosys; do ((i++)); [ gawk "BEGIN { N=`echo $(OBJS) yosys | wc -w`; printf \"%3d\", 100*$I/N; exit; }")%] Building $@"; Q = @ S = -s +else +I = +P = +Q = +S = endif OBJS += kernel/driver.o kernel/register.o kernel/rtlil.o kernel/log.o kernel/calc.o |