diff options
author | Marcus Comstedt <marcus@mc.pp.se> | 2020-10-27 14:04:28 +0100 |
---|---|---|
committer | Marcus Comstedt <marcus@mc.pp.se> | 2020-11-07 16:02:49 +0100 |
commit | 5594594e1604ff2db34e9844be206c6ae17d3838 (patch) | |
tree | 9f19efb53d566e3dd352e68a07ccdc271289c0f7 /Makefile | |
parent | e2a39bb1e71b97d423a3c2233abce996376e25dd (diff) | |
download | yosys-5594594e1604ff2db34e9844be206c6ae17d3838.tar.gz yosys-5594594e1604ff2db34e9844be206c6ae17d3838.tar.bz2 yosys-5594594e1604ff2db34e9844be206c6ae17d3838.zip |
Prevent CXXFLAGS from leaking to abc Makefile
This fixes an issue with abc/depends.sh when the compiler is clang.
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -661,6 +661,10 @@ ifeq ($(LINK_ABC),1) OBJS += $(PROGRAM_PREFIX)yosys-libabc.a endif +# prevent the CXXFLAGS set by this Makefile from reaching abc/Makefile, +# especially the -MD flag which will break the build when CXX is clang +unexport CXXFLAGS + top-all: $(TARGETS) $(EXTRA_TARGETS) @echo "" @echo " Build successful." |