aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2018-10-16 16:44:58 +0200
committerClifford Wolf <clifford@clifford.at>2018-10-16 16:44:58 +0200
commit6e00c217ae4e1509e06e586533705c13baae8a52 (patch)
tree54c6ffaca9b317a11a87c25abe43ce71034d1d70 /Makefile
parent4d4665b23a0c9ce58959490fd7bb0ad54465680d (diff)
downloadyosys-6e00c217ae4e1509e06e586533705c13baae8a52.tar.gz
yosys-6e00c217ae4e1509e06e586533705c13baae8a52.tar.bz2
yosys-6e00c217ae4e1509e06e586533705c13baae8a52.zip
After release is before release
Signed-off-by: Clifford Wolf <clifford@clifford.at>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d759b1145..ec0752535 100644
--- a/Makefile
+++ b/Makefile
@@ -99,7 +99,7 @@ LDFLAGS += -rdynamic
LDLIBS += -lrt
endif
-YOSYS_VER := 0.8
+YOSYS_VER := 0.8+$(shell cd $(YOSYS_SRC) && test -e .git && { git log --author=clifford@clifford.at --oneline 4d4665b.. | wc -l; })
GIT_REV := $(shell cd $(YOSYS_SRC) && git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
OBJS = kernel/version_$(GIT_REV).o