aboutsummaryrefslogtreecommitdiffstats
path: root/docs/source/CHAPTER_Prog.rst
diff options
context:
space:
mode:
authorKrystalDelusion <93062060+KrystalDelusion@users.noreply.github.com>2022-11-25 03:56:44 +1300
committerGitHub <noreply@github.com>2022-11-24 15:56:44 +0100
commitb9b5899cceb392c0069345c5b43c37bfe8346116 (patch)
tree557cb31d96b2224891c7ed37a9b25d3d8caa7d2e /docs/source/CHAPTER_Prog.rst
parentfc2f622a27dbc604a4acce68bea8c20b208c1742 (diff)
downloadyosys-b9b5899cceb392c0069345c5b43c37bfe8346116.tar.gz
yosys-b9b5899cceb392c0069345c5b43c37bfe8346116.tar.bz2
yosys-b9b5899cceb392c0069345c5b43c37bfe8346116.zip
Remove docs dependency on yosys repo (#3558)
* Copies guidelines files into docs/ for website * Copying manual/CHAPTER_Prog for new docs * Copying manual/APPNOTE_011... for new docs Also adding faketime to list of packages for website build. Co-authored-by: KrystalDelusion <krystinedawn@yosyshq.com>
Diffstat (limited to 'docs/source/CHAPTER_Prog.rst')
-rw-r--r--docs/source/CHAPTER_Prog.rst18
1 files changed, 9 insertions, 9 deletions
diff --git a/docs/source/CHAPTER_Prog.rst b/docs/source/CHAPTER_Prog.rst
index f706123aa..23aeed5a5 100644
--- a/docs/source/CHAPTER_Prog.rst
+++ b/docs/source/CHAPTER_Prog.rst
@@ -15,11 +15,11 @@ The guidelines directory contains notes on various aspects of Yosys
development. The files GettingStarted and CodingStyle may be of
particular interest, and are reproduced here.
-.. literalinclude:: ../../guidelines/GettingStarted
+.. literalinclude:: temp/GettingStarted
:language: none
:caption: guidelines/GettingStarted
-.. literalinclude:: ../../guidelines/CodingStyle
+.. literalinclude:: temp/CodingStyle
:language: none
:caption: guidelines/CodingStyle
@@ -28,19 +28,19 @@ The "stubsnets" example module
The following is the complete code of the "stubsnets" example module. It
is included in the Yosys source distribution as
-manual/CHAPTER_Prog/stubnets.cc.
+docs/source/CHAPTER_Prog/stubnets.cc.
-.. literalinclude:: ../../manual/CHAPTER_Prog/stubnets.cc
+.. literalinclude:: CHAPTER_Prog/stubnets.cc
:language: c++
:linenos:
- :caption: manual/CHAPTER_Prog/stubnets.cc
+ :caption: docs/source/CHAPTER_Prog/stubnets.cc
-.. literalinclude:: ../../manual/CHAPTER_Prog/Makefile
+.. literalinclude:: CHAPTER_Prog/Makefile
:language: makefile
:linenos:
- :caption: manual/CHAPTER_Prog/Makefile
+ :caption: docs/source/CHAPTER_Prog/Makefile
-.. literalinclude:: ../../manual/CHAPTER_Prog/test.v
+.. literalinclude:: CHAPTER_Prog/test.v
:language: verilog
:linenos:
- :caption: manual/CHAPTER_Prog/test.v
+ :caption: docs/source/CHAPTER_Prog/test.v