aboutsummaryrefslogtreecommitdiffstats
path: root/examples/smtbmc/Makefile
diff options
context:
space:
mode:
authorAlberto Gonzalez <boqwxp@airmail.cc>2020-04-24 08:23:08 +0000
committerAlberto Gonzalez <boqwxp@airmail.cc>2020-07-01 19:51:46 +0000
commitca3844d44e07a86d22d6026861cd405f80b0d321 (patch)
tree346ecef15ece5fd8ea033749e9aff0599c3c61f2 /examples/smtbmc/Makefile
parent72cebef279357435cde115851bc095375763108c (diff)
downloadyosys-ca3844d44e07a86d22d6026861cd405f80b0d321.tar.gz
yosys-ca3844d44e07a86d22d6026861cd405f80b0d321.tar.bz2
yosys-ca3844d44e07a86d22d6026861cd405f80b0d321.zip
glift: Add examples, including a number of benchmarks used in some academic works.
Diffstat (limited to 'examples/smtbmc/Makefile')
-rw-r--r--examples/smtbmc/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/smtbmc/Makefile b/examples/smtbmc/Makefile
index 61994f942..af937ea74 100644
--- a/examples/smtbmc/Makefile
+++ b/examples/smtbmc/Makefile
@@ -1,5 +1,5 @@
-all: demo1 demo2 demo3 demo4 demo5 demo6 demo7 demo8 demo9
+all: demo1 demo2 demo3 demo4 demo5 demo6 demo7 demo8 demo9 glift_mux
demo1: demo1.smt2
yosys-smtbmc --dump-vcd demo1.vcd demo1.smt2
@@ -31,6 +31,9 @@ demo8: demo8.smt2
demo9: demo9.smt2
yosys-smtbmc -s z3 -t 1 -g demo9.smt2
+glift_mux:
+ yosys -ql glift_mux.yslog glift/mux2.ys
+
demo1.smt2: demo1.v
yosys -ql demo1.yslog -p 'read_verilog -formal demo1.v; prep -top demo1 -nordff; write_smt2 -wires demo1.smt2'
@@ -68,6 +71,7 @@ clean:
rm -f demo7.yslog demo7.smt2
rm -f demo8.yslog demo8.smt2
rm -f demo9.yslog demo9.smt2
+ rm -f glift_mux.ys
.PHONY: demo1 demo2 demo3 demo4 demo5 demo6 demo7 demo8 demo9 clean