aboutsummaryrefslogtreecommitdiffstats
path: root/manual/CHAPTER_Prog.tex
diff options
context:
space:
mode:
authorKrystalDelusion <krystinedawn@yosyshq.com>2022-12-08 05:54:08 +1300
committerKrystalDelusion <krystinedawn@yosyshq.com>2022-12-08 05:54:08 +1300
commit1eec255e60f2854b4dd1fa212f02d57eb31c9f19 (patch)
tree9aae278e98bb5f210061c22bcf22d40854d98e8c /manual/CHAPTER_Prog.tex
parent4b95fac13934a39525a934329648cf76e4b4f219 (diff)
downloadyosys-1eec255e60f2854b4dd1fa212f02d57eb31c9f19.tar.gz
yosys-1eec255e60f2854b4dd1fa212f02d57eb31c9f19.tar.bz2
yosys-1eec255e60f2854b4dd1fa212f02d57eb31c9f19.zip
Removing manual files
Diffstat (limited to 'manual/CHAPTER_Prog.tex')
-rw-r--r--manual/CHAPTER_Prog.tex27
1 files changed, 0 insertions, 27 deletions
diff --git a/manual/CHAPTER_Prog.tex b/manual/CHAPTER_Prog.tex
deleted file mode 100644
index 49432f73b..000000000
--- a/manual/CHAPTER_Prog.tex
+++ /dev/null
@@ -1,27 +0,0 @@
-
-\chapter{Programming Yosys Extensions}
-\label{chapter:prog}
-
-This chapter contains some bits and pieces of information about programming
-yosys extensions. Also consult the section on programming in the ``Yosys
-Presentation'' (can be downloaded from the Yosys website as PDF) and don't
-be afraid to ask questions on the YosysHQ Slack.
-
-\section{Guidelines}
-
-The {\tt guidelines} directory contains notes on various aspects of Yosys development. The files {\tt GettingStarted} and {\tt CodingStyle} may be of particular interest, and are reproduced here.
-
-\lstinputlisting[title=GettingStarted,numbers=left,frame=single]{../guidelines/GettingStarted}
-
-\lstinputlisting[title=CodingStyle,numbers=left,frame=single]{../guidelines/CodingStyle}
-
-\section{The ``stubsnets'' Example Module}
-
-The following is the complete code of the ``stubsnets'' example module. It is included in the Yosys source distribution as {\tt manual/CHAPTER\_Prog/stubnets.cc}.
-
-
-\lstinputlisting[title=stubnets.cc,numbers=left,frame=single,language=C++]{CHAPTER_Prog/stubnets.cc}
-
-\lstinputlisting[title=Makefile,numbers=left,frame=single,language=make]{CHAPTER_Prog/Makefile}
-
-\lstinputlisting[title=test.v,numbers=left,frame=single,language=Verilog]{CHAPTER_Prog/test.v}