aboutsummaryrefslogtreecommitdiffstats
path: root/manual/CHAPTER_Prog.tex
diff options
context:
space:
mode:
authorPeter Gadfort <peter.gadfort@gmail.com>2023-01-02 12:46:41 -0500
committerPeter Gadfort <peter.gadfort@gmail.com>2023-01-02 12:46:41 -0500
commit7971154e727cc4d7c4b8c62ad43a28645bb66795 (patch)
treeea4632f116b272bc15940cc59f45a73eef008566 /manual/CHAPTER_Prog.tex
parent58cca9592d64178a097c6345a576b1df022cd50c (diff)
parent583ab81670847bc0084708bab04c64cb43bc3a51 (diff)
downloadyosys-7971154e727cc4d7c4b8c62ad43a28645bb66795.tar.gz
yosys-7971154e727cc4d7c4b8c62ad43a28645bb66795.tar.bz2
yosys-7971154e727cc4d7c4b8c62ad43a28645bb66795.zip
Merge branch 'master' into stat-json-area
Diffstat (limited to 'manual/CHAPTER_Prog.tex')
-rw-r--r--manual/CHAPTER_Prog.tex27
1 files changed, 0 insertions, 27 deletions
diff --git a/manual/CHAPTER_Prog.tex b/manual/CHAPTER_Prog.tex
deleted file mode 100644
index 49432f73b..000000000
--- a/manual/CHAPTER_Prog.tex
+++ /dev/null
@@ -1,27 +0,0 @@
-
-\chapter{Programming Yosys Extensions}
-\label{chapter:prog}
-
-This chapter contains some bits and pieces of information about programming
-yosys extensions. Also consult the section on programming in the ``Yosys
-Presentation'' (can be downloaded from the Yosys website as PDF) and don't
-be afraid to ask questions on the YosysHQ Slack.
-
-\section{Guidelines}
-
-The {\tt guidelines} directory contains notes on various aspects of Yosys development. The files {\tt GettingStarted} and {\tt CodingStyle} may be of particular interest, and are reproduced here.
-
-\lstinputlisting[title=GettingStarted,numbers=left,frame=single]{../guidelines/GettingStarted}
-
-\lstinputlisting[title=CodingStyle,numbers=left,frame=single]{../guidelines/CodingStyle}
-
-\section{The ``stubsnets'' Example Module}
-
-The following is the complete code of the ``stubsnets'' example module. It is included in the Yosys source distribution as {\tt manual/CHAPTER\_Prog/stubnets.cc}.
-
-
-\lstinputlisting[title=stubnets.cc,numbers=left,frame=single,language=C++]{CHAPTER_Prog/stubnets.cc}
-
-\lstinputlisting[title=Makefile,numbers=left,frame=single,language=make]{CHAPTER_Prog/Makefile}
-
-\lstinputlisting[title=test.v,numbers=left,frame=single,language=Verilog]{CHAPTER_Prog/test.v}