aboutsummaryrefslogtreecommitdiffstats
path: root/manual/CHAPTER_Prog/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-01-28 06:55:47 +0100
committerClifford Wolf <clifford@clifford.at>2014-01-28 06:55:47 +0100
commit2cb47355d4b3e8021a88f68f7a5f33ce46ff51b0 (patch)
tree83a3e52f3a46f2db264106798e416da63e7ae743 /manual/CHAPTER_Prog/Makefile
parent842ca2f011a6030faccc690986accb0ca8035ec8 (diff)
downloadyosys-2cb47355d4b3e8021a88f68f7a5f33ce46ff51b0.tar.gz
yosys-2cb47355d4b3e8021a88f68f7a5f33ce46ff51b0.tar.bz2
yosys-2cb47355d4b3e8021a88f68f7a5f33ce46ff51b0.zip
Renamed manual/FILES_* directories
Diffstat (limited to 'manual/CHAPTER_Prog/Makefile')
-rw-r--r--manual/CHAPTER_Prog/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/manual/CHAPTER_Prog/Makefile b/manual/CHAPTER_Prog/Makefile
new file mode 100644
index 000000000..8e326bdc2
--- /dev/null
+++ b/manual/CHAPTER_Prog/Makefile
@@ -0,0 +1,12 @@
+test: stubnets.so
+ yosys -ql test1.log -m ./stubnets.so test.v -p "stubnets"
+ yosys -ql test2.log -m ./stubnets.so test.v -p "opt; stubnets"
+ yosys -ql test3.log -m ./stubnets.so test.v -p "techmap; opt; stubnets -report_bits"
+ tail test1.log test2.log test3.log
+
+stubnets.so: stubnets.cc
+ yosys-config --exec --cxx --cxxflags --ldflags -o $@ -shared $^ --ldlibs
+
+clean:
+ rm -f test1.log test2.log test3.log
+ rm -f stubnets.so stubnets.d