aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/altera_intel/Makefile.inc
diff options
context:
space:
mode:
authordh73 <dh73_fpga@qq.com>2017-04-05 23:01:29 -0500
committerdh73 <dh73_fpga@qq.com>2017-04-05 23:01:29 -0500
commitc27dcc1e47fa00cd415893c9d3f637a5d5865988 (patch)
treef474149e35f09f18cc6ff701ec03c667bd76477c /techlibs/altera_intel/Makefile.inc
parentfcb274a5644016c4090cdfbfbd795f311a7e58f5 (diff)
downloadyosys-c27dcc1e47fa00cd415893c9d3f637a5d5865988.tar.gz
yosys-c27dcc1e47fa00cd415893c9d3f637a5d5865988.tar.bz2
yosys-c27dcc1e47fa00cd415893c9d3f637a5d5865988.zip
Add initial support for both MAX10 and Cyclone IV (E|GX) FPGAs
Diffstat (limited to 'techlibs/altera_intel/Makefile.inc')
-rw-r--r--techlibs/altera_intel/Makefile.inc10
1 files changed, 10 insertions, 0 deletions
diff --git a/techlibs/altera_intel/Makefile.inc b/techlibs/altera_intel/Makefile.inc
new file mode 100644
index 000000000..56ee56e88
--- /dev/null
+++ b/techlibs/altera_intel/Makefile.inc
@@ -0,0 +1,10 @@
+
+OBJS += techlibs/altera_intel/synth_intel.o
+
+#$(eval $(call add_share_file,share/altera_intel,techlibs/altera_intel/lpm_functions.v))
+$(eval $(call add_share_file,share/altera_intel/max10,techlibs/altera_intel/max10/cells_comb_max10.v))
+$(eval $(call add_share_file,share/altera_intel/cycloneiv,techlibs/altera_intel/cycloneiv/cells_comb_cycloneiv.v))
+$(eval $(call add_share_file,share/altera_intel/max10,techlibs/altera_intel/max10/cells_map_max10.v))
+$(eval $(call add_share_file,share/altera_intel/cycloneiv,techlibs/altera_intel/cycloneiv/cells_map_cycloneiv.v))
+#$(eval $(call add_share_file,share/altera_intel/max10,techlibs/altera_intel/max10/cells_arith_max10.v))
+