aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/anlogic
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2018-12-23 15:44:19 +0100
committerClifford Wolf <clifford@clifford.at>2018-12-23 15:44:19 +0100
commitd938ce7ab6df091e0edd40f85f08fcd5458d9d6d (patch)
tree1e7f17e720b7ab491cfd1defebef35f07dfb5de1 /techlibs/anlogic
parent23bb77867f56e966195d99d1d89b45d510d0b92d (diff)
parente5eb3d2c8ace00aeedec410d17a4972a76782089 (diff)
downloadyosys-d938ce7ab6df091e0edd40f85f08fcd5458d9d6d.tar.gz
yosys-d938ce7ab6df091e0edd40f85f08fcd5458d9d6d.tar.bz2
yosys-d938ce7ab6df091e0edd40f85f08fcd5458d9d6d.zip
Merge branch 'master' of github.com:YosysHQ/yosys
Diffstat (limited to 'techlibs/anlogic')
-rw-r--r--techlibs/anlogic/Makefile.inc1
-rw-r--r--techlibs/anlogic/drams.txt2
-rw-r--r--techlibs/anlogic/synth_anlogic.cc2
3 files changed, 3 insertions, 2 deletions
diff --git a/techlibs/anlogic/Makefile.inc b/techlibs/anlogic/Makefile.inc
index 59be83fd0..f37b5e7e9 100644
--- a/techlibs/anlogic/Makefile.inc
+++ b/techlibs/anlogic/Makefile.inc
@@ -5,5 +5,6 @@ OBJS += techlibs/anlogic/anlogic_eqn.o
$(eval $(call add_share_file,share/anlogic,techlibs/anlogic/cells_map.v))
$(eval $(call add_share_file,share/anlogic,techlibs/anlogic/arith_map.v))
$(eval $(call add_share_file,share/anlogic,techlibs/anlogic/cells_sim.v))
+$(eval $(call add_share_file,share/anlogic,techlibs/anlogic/eagle_bb.v))
$(eval $(call add_share_file,share/anlogic,techlibs/anlogic/drams.txt))
$(eval $(call add_share_file,share/anlogic,techlibs/anlogic/drams_map.v))
diff --git a/techlibs/anlogic/drams.txt b/techlibs/anlogic/drams.txt
index 2bff14a03..eb94775ae 100644
--- a/techlibs/anlogic/drams.txt
+++ b/techlibs/anlogic/drams.txt
@@ -1,7 +1,7 @@
bram $__ANLOGIC_DRAM16X4
init 0
abits 4
- dbits 2
+ dbits 4
groups 2
ports 1 1
wrmode 0 1
diff --git a/techlibs/anlogic/synth_anlogic.cc b/techlibs/anlogic/synth_anlogic.cc
index a4eafeddf..9c44599ea 100644
--- a/techlibs/anlogic/synth_anlogic.cc
+++ b/techlibs/anlogic/synth_anlogic.cc
@@ -176,7 +176,7 @@ struct SynthAnlogicPass : public ScriptPass
if (check_label("map_luts"))
{
- run("abc -lut 6");
+ run("abc -lut 4:6");
run("clean");
}