aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/common/Makefile.inc
diff options
context:
space:
mode:
authorMiodrag Milanović <mmicko@gmail.com>2019-10-19 08:58:02 +0200
committerGitHub <noreply@github.com>2019-10-19 08:58:02 +0200
commitf2aa2d1bb470235689959748aa2d4f82a1c0d0b5 (patch)
tree78f82dfdc3c13c9d8809be4081db6d67abc99bb6 /techlibs/common/Makefile.inc
parente8ef3fcdfcacbc711a4722deee95f0707634bed0 (diff)
parent82f60ba938749ab20694f9070f1046e393f16f3c (diff)
downloadyosys-f2aa2d1bb470235689959748aa2d4f82a1c0d0b5.tar.gz
yosys-f2aa2d1bb470235689959748aa2d4f82a1c0d0b5.tar.bz2
yosys-f2aa2d1bb470235689959748aa2d4f82a1c0d0b5.zip
Merge pull request #1457 from xobs/python-binary-name
Makefile: don't assume python is called `python3`
Diffstat (limited to 'techlibs/common/Makefile.inc')
-rw-r--r--techlibs/common/Makefile.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
index 6c0a4fe66..a42f63128 100644
--- a/techlibs/common/Makefile.inc
+++ b/techlibs/common/Makefile.inc
@@ -9,12 +9,12 @@ GENFILES += techlibs/common/simcells_help.inc
techlibs/common/simlib_help.inc: techlibs/common/cellhelp.py techlibs/common/simlib.v
$(Q) mkdir -p techlibs/common
- $(P) python3 $^ > $@.new
+ $(P) $(PYTHON_EXECUTABLE) $^ > $@.new
$(Q) mv $@.new $@
techlibs/common/simcells_help.inc: techlibs/common/cellhelp.py techlibs/common/simcells.v
$(Q) mkdir -p techlibs/common
- $(P) python3 $^ > $@.new
+ $(P) $(PYTHON_EXECUTABLE) $^ > $@.new
$(Q) mv $@.new $@
kernel/register.o: techlibs/common/simlib_help.inc techlibs/common/simcells_help.inc