aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/common
diff options
context:
space:
mode:
authorEddie Hung <eddie@fpgeh.com>2020-03-02 12:32:27 -0800
committerGitHub <noreply@github.com>2020-03-02 12:32:27 -0800
commit4f889b2f57b732083dd4bf336a0d361f70e5b2d0 (patch)
tree5f8e46c0273e9e9bee1d6e6a6775b3f58ec302da /techlibs/common
parentb1e248b0e6c7945870c83ac82bfb4ed8e9d8ff66 (diff)
parent090e54569a58b26d616806337c28507d199ca43c (diff)
downloadyosys-4f889b2f57b732083dd4bf336a0d361f70e5b2d0.tar.gz
yosys-4f889b2f57b732083dd4bf336a0d361f70e5b2d0.tar.bz2
yosys-4f889b2f57b732083dd4bf336a0d361f70e5b2d0.zip
Merge pull request #1724 from YosysHQ/eddie/abc9_specify
abc9: auto-generate *.lut/*.box files and arrival/required times from specify entries
Diffstat (limited to 'techlibs/common')
-rw-r--r--techlibs/common/Makefile.inc1
-rw-r--r--techlibs/common/abc9_model.v10
2 files changed, 11 insertions, 0 deletions
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
index 42f1068ad..d5e69a241 100644
--- a/techlibs/common/Makefile.inc
+++ b/techlibs/common/Makefile.inc
@@ -29,3 +29,4 @@ $(eval $(call add_share_file,share,techlibs/common/gate2lut.v))
$(eval $(call add_share_file,share,techlibs/common/cmp2lut.v))
$(eval $(call add_share_file,share,techlibs/common/cells.lib))
$(eval $(call add_share_file,share,techlibs/common/mul2dsp.v))
+$(eval $(call add_share_file,share,techlibs/common/abc9_model.v))
diff --git a/techlibs/common/abc9_model.v b/techlibs/common/abc9_model.v
new file mode 100644
index 000000000..c0c5dc2fd
--- /dev/null
+++ b/techlibs/common/abc9_model.v
@@ -0,0 +1,10 @@
+module \$__ABC9_FF_ (input D, output Q);
+endmodule
+
+(* abc9_box *)
+module \$__ABC9_DELAY (input I, output O);
+ parameter DELAY = 0;
+ specify
+ (I => O) = DELAY;
+ endspecify
+endmodule