aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/gatemate/Makefile.inc
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-12-07 13:41:39 +0000
committermyrtle <gatecat@ds0.me>2022-06-27 10:09:48 +0100
commit38a24ec5cc3ae25d46a306bceb94244fad787a19 (patch)
tree2fcc77f43fe2103fbe476217fce4d9329fe5b99a /techlibs/gatemate/Makefile.inc
parent7c756c9959b61160ea62b56c13c58371cb2b401c (diff)
downloadyosys-38a24ec5cc3ae25d46a306bceb94244fad787a19.tar.gz
yosys-38a24ec5cc3ae25d46a306bceb94244fad787a19.tar.bz2
yosys-38a24ec5cc3ae25d46a306bceb94244fad787a19.zip
gatemate: Add LUT tree library script
Co-authored-by: Claire Xenia Wolf <claire@clairexen.net> Signed-off-by: gatecat <gatecat@ds0.me>
Diffstat (limited to 'techlibs/gatemate/Makefile.inc')
-rw-r--r--techlibs/gatemate/Makefile.inc16
1 files changed, 16 insertions, 0 deletions
diff --git a/techlibs/gatemate/Makefile.inc b/techlibs/gatemate/Makefile.inc
index d1341d7bb..aeb318cc9 100644
--- a/techlibs/gatemate/Makefile.inc
+++ b/techlibs/gatemate/Makefile.inc
@@ -1,5 +1,6 @@
OBJS += techlibs/gatemate/synth_gatemate.o
+OBJS += techlibs/gatemate/gatemate_foldinv.o
$(eval $(call add_share_file,share/gatemate,techlibs/gatemate/reg_map.v))
$(eval $(call add_share_file,share/gatemate,techlibs/gatemate/mux_map.v))
@@ -12,3 +13,18 @@ $(eval $(call add_share_file,share/gatemate,techlibs/gatemate/brams_map.v))
$(eval $(call add_share_file,share/gatemate,techlibs/gatemate/brams.txt))
$(eval $(call add_share_file,share/gatemate,techlibs/gatemate/brams_init_20.vh))
$(eval $(call add_share_file,share/gatemate,techlibs/gatemate/brams_init_40.vh))
+$(eval $(call add_share_file,share/gatemate,techlibs/gatemate/inv_map.v))
+
+EXTRA_OBJS += techlibs/gatemate/lut_tree_lib.mk
+.SECONDARY: techlibs/gatemate/lut_tree_lib.mk
+
+techlibs/gatemate/lut_tree_lib.mk: techlibs/gatemate/make_lut_tree_lib.py
+ $(Q) mkdir -p techlibs/gatemate
+ $(P) $(PYTHON_EXECUTABLE) $<
+ $(Q) touch $@
+
+techlibs/gatemate/lut_tree_cells.genlib: techlibs/gatemate/lut_tree_lib.mk
+techlibs/gatemate/lut_tree_map.v: techlibs/gatemate/lut_tree_lib.mk
+
+$(eval $(call add_gen_share_file,share/gatemate,techlibs/gatemate/lut_tree_cells.genlib))
+$(eval $(call add_gen_share_file,share/gatemate,techlibs/gatemate/lut_tree_map.v))