aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/gowin/Makefile.inc
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2019-11-19 17:29:27 +0100
committerGitHub <noreply@github.com>2019-11-19 17:29:27 +0100
commit7ea0a5937ba2572f6d9d62e73e24df480c49561d (patch)
tree7825f438b83fdc730764ba15016eeeac9eb0cf41 /techlibs/gowin/Makefile.inc
parent15232a48af60fb7da3c3afdd144882ace2194197 (diff)
parent8ab412eb16b1d4f98117247bf85e0c37627ee459 (diff)
downloadyosys-7ea0a5937ba2572f6d9d62e73e24df480c49561d.tar.gz
yosys-7ea0a5937ba2572f6d9d62e73e24df480c49561d.tar.bz2
yosys-7ea0a5937ba2572f6d9d62e73e24df480c49561d.zip
Merge pull request #1449 from pepijndevos/gowin
Improvements for gowin support
Diffstat (limited to 'techlibs/gowin/Makefile.inc')
-rw-r--r--techlibs/gowin/Makefile.inc10
1 files changed, 10 insertions, 0 deletions
diff --git a/techlibs/gowin/Makefile.inc b/techlibs/gowin/Makefile.inc
index 6f2159349..d2853704b 100644
--- a/techlibs/gowin/Makefile.inc
+++ b/techlibs/gowin/Makefile.inc
@@ -15,3 +15,13 @@ $(eval $(call add_share_file,share/gowin,techlibs/gowin/dram.txt))
$(eval $(call add_share_file,share/gowin,techlibs/gowin/brams_init3.vh))
+EXTRA_OBJS += techlibs/gowin/brams_init.mk
+.SECONDARY: techlibs/gowin/brams_init.mk
+
+techlibs/gowin/brams_init.mk: techlibs/gowin/brams_init.py
+ $(Q) mkdir -p techlibs/gowin
+ $(P) python3 $<
+ $(Q) touch $@
+
+techlibs/gowin/bram_init_16.vh: techlibs/gowin/brams_init.mk
+$(eval $(call add_gen_share_file,share/gowin,techlibs/gowin/bram_init_16.vh))