aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/intel_alm/Makefile.inc
diff options
context:
space:
mode:
authorLofty <dan.ravensloft@gmail.com>2020-07-13 14:08:52 +0100
committerMarcelina Koƛcielnicka <mwk@0x04.net>2020-07-13 18:05:38 +0200
commita3a90f6377f251d3b6c5898eb1543f8832493bb8 (patch)
tree675edf92b662112079a0b3384d406b8f5526a3de /techlibs/intel_alm/Makefile.inc
parent38b814b525d9d3abbfea060a8156b64b15aa7cf3 (diff)
downloadyosys-a3a90f6377f251d3b6c5898eb1543f8832493bb8.tar.gz
yosys-a3a90f6377f251d3b6c5898eb1543f8832493bb8.tar.bz2
yosys-a3a90f6377f251d3b6c5898eb1543f8832493bb8.zip
Revert "intel_alm: direct M10K instantiation"
This reverts commit 09ecb9b2cf3ab76841d30712bf70dafc6d47ef67.
Diffstat (limited to 'techlibs/intel_alm/Makefile.inc')
-rw-r--r--techlibs/intel_alm/Makefile.inc6
1 files changed, 3 insertions, 3 deletions
diff --git a/techlibs/intel_alm/Makefile.inc b/techlibs/intel_alm/Makefile.inc
index e36c81c0e..552f00c65 100644
--- a/techlibs/intel_alm/Makefile.inc
+++ b/techlibs/intel_alm/Makefile.inc
@@ -15,9 +15,9 @@ $(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/ds
$(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/mem_sim.v))
# RAM
-$(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/bram_m10k.txt))
-$(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/bram_m20k.txt))
-$(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/bram_m20k_map.v))
+bramtypes := m10k m20k
+$(foreach bramtype, $(bramtypes), $(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/bram_$(bramtype).txt)))
+$(foreach bramtype, $(bramtypes), $(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/bram_$(bramtype)_map.v)))
$(eval $(call add_share_file,share/intel_alm/common,techlibs/intel_alm/common/lutram_mlab.txt))
# Miscellaneous