aboutsummaryrefslogtreecommitdiffstats
path: root/tests/anlogic/run-test.sh
diff options
context:
space:
mode:
authorMiodrag Milanović <mmicko@gmail.com>2019-10-18 10:54:04 +0200
committerGitHub <noreply@github.com>2019-10-18 10:54:04 +0200
commitab4899a2d02b994d79e4aa223eb743793b9a60b3 (patch)
treea78b5d92952ea9f95623bb3daf8028d2402d023b /tests/anlogic/run-test.sh
parent5ffb0053ec7d53ffc5c57e3277bfbab5d3fddb54 (diff)
parent66fca65b58bfb944cad45da5836613726498e4b7 (diff)
downloadyosys-ab4899a2d02b994d79e4aa223eb743793b9a60b3.tar.gz
yosys-ab4899a2d02b994d79e4aa223eb743793b9a60b3.tar.bz2
yosys-ab4899a2d02b994d79e4aa223eb743793b9a60b3.zip
Merge pull request #1434 from YosysHQ/mmicko/anlogic
Add tests for Anlogic architecture (contd)
Diffstat (limited to 'tests/anlogic/run-test.sh')
-rwxr-xr-xtests/anlogic/run-test.sh20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/anlogic/run-test.sh b/tests/anlogic/run-test.sh
new file mode 100755
index 000000000..46716f9a0
--- /dev/null
+++ b/tests/anlogic/run-test.sh
@@ -0,0 +1,20 @@
+#!/usr/bin/env bash
+set -e
+{
+echo "all::"
+for x in *.ys; do
+ echo "all:: run-$x"
+ echo "run-$x:"
+ echo " @echo 'Running $x..'"
+ echo " @../../yosys -ql ${x%.ys}.log -w 'Yosys has only limited support for tri-state logic at the moment.' $x"
+done
+for s in *.sh; do
+ if [ "$s" != "run-test.sh" ]; then
+ echo "all:: run-$s"
+ echo "run-$s:"
+ echo " @echo 'Running $s..'"
+ echo " @bash $s"
+ fi
+done
+} > run-test.mk
+exec ${MAKE:-make} -f run-test.mk