aboutsummaryrefslogtreecommitdiffstats
path: root/tests/memlib/run-test.sh
diff options
context:
space:
mode:
authorMarcelina Koƛcielnicka <mwk@0x04.net>2022-05-06 16:30:56 +0200
committerMarcelina Koƛcielnicka <mwk@0x04.net>2022-05-18 17:32:56 +0200
commit982a11c709b4b363f85ae52a127f8a98bda30a3f (patch)
treede2dd78747314064b3a7731fc4791b0ec7bfb77d /tests/memlib/run-test.sh
parent2a2dc12eb69f2e904609e5b8275ec885e21ecd26 (diff)
downloadyosys-982a11c709b4b363f85ae52a127f8a98bda30a3f.tar.gz
yosys-982a11c709b4b363f85ae52a127f8a98bda30a3f.tar.bz2
yosys-982a11c709b4b363f85ae52a127f8a98bda30a3f.zip
Add memory_libmap tests.
Diffstat (limited to 'tests/memlib/run-test.sh')
-rwxr-xr-xtests/memlib/run-test.sh15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/memlib/run-test.sh b/tests/memlib/run-test.sh
new file mode 100755
index 000000000..abe88a6cb
--- /dev/null
+++ b/tests/memlib/run-test.sh
@@ -0,0 +1,15 @@
+#!/bin/bash
+set -eu
+
+OPTIND=1
+seed="" # default to no seed specified
+while getopts "S:" opt
+do
+ case "$opt" in
+ S) seed="$OPTARG" ;;
+ esac
+done
+shift "$((OPTIND-1))"
+
+python3 generate.py
+exec ${MAKE:-make} -f run-test.mk SEED="$seed"